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Preface

Purpose of this document

This getting results guide provides you with information on how to install and navigate 
the RSNetWorx™ for EtherNet/IP™ software. It explains how to effectively use the 
RSNetWorx for EtherNet/IP software and how to access and navigate the online help.

Intended audience

We assume that you are familiar with:

 IBM®-compliant personal computers
 Microsoft® Windows® operating systems
 RSLinx® Classic™ communications software

How does the Getting Results Guide fit in with other Rockwell 
Software product documentation?

The Getting Results with RSNetWorx for EtherNet/IP guide can be considered the entry 
point into Rockwell Software’s documentation set for this product. Other components of 
the documentation set include online help, product manuals, a product tutorial, and 
electronic release notes.

The documentation set contains pertinent, easily accessible product information. This set 
ships with the software product, and is designed to free you from tedious paper shuffling 
and reduce information overload.

Online help
The online help includes all overview, procedural, screen, and reference information for 
the product. The help contains these basic components: overview topics, quick start 
topics, step-by-step procedures, troubleshooting topics, and screen element descriptions 
(for example, text boxes, drop-down lists, and option buttons). All of the help is context-
sensitive with the application and provides you with immediate access to application tasks 
and screen element descriptions. Refer to the “Finding the information you need” chapter 
in this guide for a more detailed description of the online help.

Product Manuals
Within RSNetWorx for EtherNet/IP, we provide a Product Manuals feature that allows 
you to immediately access and search your product documentation from the Help menu. 
This feature includes the Getting Results with RSNetWorx for EtherNet/IP guide, as well 
iii
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as several hardware product reference guides, in an electronic book format. As a part of 
the product installation, you have the option of installing these electronic books to your 
local hard drive during installation, or access them directly from the CD-ROM.

Tutorial

RSNetWorx for EtherNet/IP contains a product tutorial, which includes basic overview 
information and specific tasks and examples for successfully working with the product. 
This tutorial is available from Start > Programs > Rockwell Software > RSNetWorx > 
RSNetWorx for EtherNet-IP Tutorial.

Document conventions

The conventions used throughout this document for the user interface comply with those 
recommended by Microsoft. If you are not familiar with the Microsoft Windows user 
interface, we recommend that you read the documentation supplied with the operating 
system you are using before attempting to use this software.

Feedback

Please use the feedback form packaged with your software to report errors or let us know 
what information you would like to see added in future editions of this document. You can 
also send an email message to info@software.rockwell.com with any comments about 
Rockwell’s products and services.

The Product Manuals included with RSNetWorx for EtherNet/IP are in portable document 
format (PDF), and must be viewed using the Adobe® Acrobat® Reader software included 
on your RSNetWorx for EtherNet/IP CD. You can install the Acrobat Reader, or run it 
directly from the CD.

Due to Windows operating system constraints, we cannot include a front slash (/) in file or 
folder names. For file and folder names, the front slash is replaced wth a dash (-).
iv
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1 • Placeholder
1 Welcome to RSNetWorx for EtherNet/IP

RSNetWorx™ for EtherNet/IP™ is a 32-bit Windows® application program that allows 
you to configure devices and lay out a network topology. From the graphical 
representation of your network, you can:

 view I/O data and configuration data for those devices that have EDS files that support 
this functionality (online only)

 display all connection information for all connections to/from a given device 
including all connections in scanners that are in the configuration

 configure scanners that adhere to the open EtherNet/IP specification for scanners, 
define scanlist entries for certain scanners, and map scanner memory onto the network 
and network data into the scanner memory (via the Scanlist Configuration Tool (SCT) 
that is bundled with RSNetWorx for EtherNet/IP)

 leverage the connection information to diagnose the health of the connections, and 
thus the health of the devices that originate and receive those connections

This chapter contains the following sections:

 Features and benefits
 Understanding EtherNet/IP concepts
 Exploring RSNetWorx for EtherNet/IP
 Quick Start steps

Features and benefits

RSNetWorx for EtherNet/IP has the following features:

 Support for Reduced Heartbeat feature of RSLogix5000 V16. The numbers on the 
Device Usage Properties dialog box in EtherNet/IP 8.0 will reflect the effect that 
Reduced Heartbeat calculations, from RSLogix 5000 V16, will have on your device's 
usage.

 Support for Unicast feature of RSLogix5000 V16. The numbers on the Device Usage 
Properties dialog box in EtherNet/IP will reflect the effect that Unicast calculations, 
from RSLogix 5000 V16, will have on your device's usage.

The Reduced Heartbeat feature helps in preserving bandwidth in large network 
installations by reducing the rate at which heartbeat is sent from the Consumer to the 
Producer device. Heartbeat is the name given to the way a Consumer device informs a 
Producer device of its presence.

In Unicast the Producer device sends individual packets to each Consumer device.
1
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 Support for FactoryTalk Activation.
 RSNetWorx supports RSAssetSecurity™. RSAssetSecurity is intended to improve the 

security of your automation system by limiting access to only those with a legitimate 
need. RSAssetSecurity authenticates user identities and authorizes user requests to 
access a FactoryTalk-enabled system. These security services are fully integrated into 
the FactoryTalk Directory and are included as part of the FactoryTalk Automation 
Platform that installs with many products.

 Device usages view displays usage percentages for factors such as minimum and 
maximum CPU. and connection usage (when your device’s EDS file contains capacity 
information) or raw transmission data information (when your device’s EDS file does 
not contain capacity information).  When edits are enabled, you will get to see both 
current and pending device usage information.

 Embedded EDS is supported. With this functionality, you can now change the state of 
your device from unknown to known by uploading and registering its EDS, instead of 
obtaining the EDS file from an external website or a CD. 

 A Windows-based point and click interface that allows you to easily configure 
EtherNet/IP networks.

 Use of RSLinx Classic communication services, which allows you to browse online 
through various networks, devices, bridges, etc., to choose the network you want to 
view or edit.

 The ability to edit configurations either online or offline.
 Simple and complete network upload/download. You can upload a configuration 

directly from the network or download a configuration to the online network. When 
you upload or download a configuration, the scanlist for the open scanners is 
transferred.

 The Scanlist Configuration Tool configures both I/O and peer-to-peer data addresses. 
It also supports target devices for Rockwell Automation and third-party devices via 
EtherNet/IP standard Electronic Data Sheet (EDS) files.

 Reports generated in HTML format.
 Comprehensive context-sensitive online help, including additional information and 

troubleshooting hints on any message that appears in the Message View.
 The ability to interconnect several network configurations for navigation.
 With RSNetWorx MD, you will also be able to:

 quickly detect and resolve conditions that arise when initially commissioning a 
system, minimizing initial start-up times and costs.

 debug and correct network/device problems, thereby reducing network downtimes 
and related costs.

 detect preventive maintenance needs within the devices on your network, thereby 
preventing system downtimes.
2
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Understanding EtherNet/IP concepts

You begin configuring your EtherNet/IP network by determining how many devices will 
be connected to your network, what EtherNet topology will be used, and what addressing 
method will be used (IP addressing, Host name addressing, or a combination of both). 
Each device must be assigned a unique IP address/host name.  You may allow the 
addresses to be automatically assigned, or choose to assign a unique address manually.

Finally, you finish creating the configuration by defining connections between the devices 
at IP addresses/host names on the network. To do this, you determine which data is to be 
consumed by each scanner, and you determine where in each scanner’s data table this data 
is placed. You may also choose to determine which scanner will maintain the 
configuration for each adapter device. After you have defined these parameters, you use 
the Scanlist Configuration Tool (for integrated scanners) or RSLogix 5000 (for Rockwell 
Automation’s Logix processors) to enter the connection into your configuration for each 
of your EtherNet/IP scanners.

For many devices, you can also use the Scanlist Configuration Tool to configure how 
outputs are set in the event of a fault, such as loss of communication to the controlling 
scanner. Depending on the information contained in a device’s EDS file, you may be able 
to configure other device parameters. These parameters may be found on the connection’s 
property page from the Configuration Settings tab and/or the Advanced Settings tab 
depending on the device or module for which you are setting the parameters.

When you are online, enable edits, and save your configuration in RSNetWorx for 
EtherNet/IP version 4.0 or later, the software displays connections that are created in 
RSLogix 5000.
3
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Exploring RSNetWorx for EtherNet/IP

When you start RSNetWorx for EtherNet/IP software, the RSNetWorx for EtherNet/IP 
window appears. It shows the current network (EtherNet is the default filename) in its 
view. The following illustration shows the RSNetWorx for EtherNet/IP window and the 
design elements associated with it. (The Message view and Favorites view will not be 
automatically shown in the default view, but may be chosen by selecting View > 
Messages > Show or View > Favorites.)  Each of the design elements are described in the 
sections following this illustration.

Toolbars

Title bar
Menu bar

Hardware 
view

Status bar

Message view Favorites view Network configuration
(Graph, Spreadsheet or Diagnostics view)
4
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Title bar
The title bar shows the RSNetworx icon, the name of the current RSNetWorx 
configuration, the name of the software product, i.e., RSNetWorx for EtherNet/IP, and the 
Minimize, Maximize, and Close buttons.

To view the Control Menu, right-click the RSNetWorx icon on the title bar. The following 
items appear on the Control Menu.

Item Description

Restore Restores the window to its former size after you enlarged it by using the 
Maximize command or shrunk it by using the Minimize command.

Move Allows you to reposition the window on the desktop using the arrow keys on the 
keyboard.

Size Allows you to resize the window by using the arrow keys on the keyboard.

Minimize Shrinks the window to an icon, which is located on the task bar. This performs 
the same function as if you clicked the Minimize button on the title bar.

Maximize Enlarges the window to occupy the entire screen. This performs the same 
function as if you clicked the Maximize button on the title bar.

Close Exits the RSNetWorx application. This performs the same function as if you 
clicked the Close button on the title bar.
5
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Menu bar
The RSNetWorx for EtherNet/IP menu bar contains the following menus:

Each menu contains options for performing the following tasks:

Online icon
The online icon displays in the right side of the RSNetWorx for EtherNet/IP window at 
the same level as the menu bar.

This icon indicates whether or not RSNetWorx for EtherNet/IP is in the online mode. If 
you toggle the Online toolbar button to online, the Online icon becomes animated. If the 
icon is not animated, RSNetWorx for EtherNet/IP is in offline mode. When online, 
RSNetWorx for EtherNet/IP writes information to the devices and to the offline file when 
you save. When offline, RSNetWorx for EtherNet/IP only updates the offline file when 
you save.

Menu Description

File New, print, open, and save a network configuration, generate reports, or exit 
RSNetWorx for EtherNet/IP.

Edit Invoke actions such as cut, copy, and paste on selected items in the network 
configuration.

View Set and change RSNetWorx for EtherNet/IP interface displays.

Network Browse the network, toggle between online and offline mode, enable and cancel 
edits, and upload and download data to and from the network.

Device Edit the properties of the selected device, chassis, or module.

Diagnostics Start and stop the diagnostic scan, add or remove devices from the diagnostic 
scan, troubleshoot a diagnostic fault, and generate a network health report.

Tools Launch the EDS Wizard and other optional tools.

Help Access help options for RSNetWorx for EtherNet/IP, EtherNet/IP related 
hardware, and other Rockwell Software products and services.
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Toolbars
The toolbars contain shortcuts to several commonly used functions. Each toolbar button is 
a graphical representation of a command (except Symbol Legend) that is also available 
from the RSNetWorx for EtherNet/IP menu bar. RSNetWorx for EtherNet/IP contains the 
standard toolbar and the tools toolbar.

The following items appear on the RSNetWorx for EtherNet/IP standard toolbar.

Icon Menu Selection Description

File > New Creates a new network configuration.

File > Open Opens an existing network configuration. The arrow to the 
right of the Open icon provides quick access to recently 
used files.

File > Save Saves the current network configuration.

File > Print Prints the current network configuration.

Edit > Cut Cuts the selected device from the network configuration 
and places it on the clipboard. If you cut a device, only the 
device, not its configuration, is retained.

Edit > Copy Copies the selected device to the clipboard. If you copy a 
device, only the device type, not its configuration, is 
retained.

Edit > Paste Pastes the device from the clipboard to the current network 
configuration.

Help > What’s This? Places the cursor in What’s This? help mode. Place the 
cursor on the control you want help with and right-click to 
see the context-sensitive help.
7
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The following items appear on the RSNetWorx for EtherNet/IP tools toolbar.

Edits enabled
The edits enabled area allows you to obtain the edit resource, enabling and disabling edits 
to the current EtherNet/IP offline configuration file (*.enet).

Icon Menu Selection Description

View > Zoom-In Increases the size of images located in the current network 
configuration. The choices available are high, medium, and 
low. Zoom-In only applies to the graph view.

View > Zoom-Out Decreases the size of the images located in the current network 
configuration. The choices available are high, medium, and 
low. Zoom-Out only applies to the graph view.

View > Hardware Displays a list of all available hardware devices.

View > Favorites Displays a list of hardware devices that you have added to your 
favorites list.

Network > Single Pass 
Browse or Network > 
Continuous Browse

Locates all currently available devices based on the drivers 
configured in RSLinx Classic. Allows you to browse once and 
stop (single pass) or browse continuously (continuous browse).

Network > Online Places RSNetWorx for EtherNet/IP in online mode. To go 
offline, click the button or choose Network > Online again.

View > Diagnostics Displays the Diagnostic view, allowing you to view the 
diagnostic parameters for all of the devices on your network, 
and indicates the current diagnostic status of your network.

View > Refresh Refreshes the window. This will reorder the graphic display by 
device address.

No menu selection Displays the Symbol Legend, which contains descriptions of 
the device comparison states. The Symbol Legend can also be 
accessed from the online help system by selecting Help > 
Contents and selecting symbol legend from the index tab.
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Hardware and Favorites views
A device can be added to the network configuration by selecting it from the Hardware 
view and dragging it to the configuration (graph or spreadsheet view). Once a device is 
added, it will display in the appropriate configuration. The Favorites view displays all 
hardware devices that you have defined as favorites by selection from the Hardware list. 
To add an item from the Hardware list to the Favorites list, select the item, right-click and 
choose Add to Favorites.

Graph or Spreadsheet view
The application workspace displays network information in either a graphic or a 
spreadsheet view.  Click the appropriate tab in the network configuration to display the 
desired view.
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Diagnostics view
RSNetWorx MD provides a hierarchial view of the real-time status (or health) of a 
network. At a glance, you can quickly and easily determine the overall status of your 
10
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network, or any device on your network, by viewing a single status indicator. Click the 
Diagnostics tab in the network configuration to display this view.

Displays any network and/or device problems 
that are detected on your network

Starts or stops the 
diagnostic scan

Displays a count 
of diagnostics 
by state

Displays the troubleshooting page for 
warning or error diagnostics
11
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Message view
The message view, which appears in the bottom portion of the workspace displays a log of 
messages. Each message consists of four parts:

 an icon
 an error message code (including a distinguishing software component designator and 

a 16-bit numeric designator)
 a timestamp that displays the date and time the message is generated
 a description of the message

This view may contain error, warning, and/or informational messages as indicated in the 
following table:

If  View > Messages has not been previously selected, the Message View will 
automatically appear when a message is logged by RSNetWorx for EtherNet/IP.

Icon Description

Error

Warning

Information
al

If you want more information on any particular message, you can select the message and 
press the F1 key to access the online help. You can Show, Clear, Copy, or Clear and Hide 
messages by making the appropriate selection from the View > Messages command on 
the main menu, or by right-clicking and selecting the Message option while in the Message 
view.
12
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Status bar
The status bar, which is located at the bottom of the RSNetWorx for EtherNet/IP main 
window, provides information about the status of the software.

The left portion of the status bar displays informational messages about the operation of 
RSNetWorx for EtherNet/IP software. For example, when you highlight a device in the 
application workspace, a brief description of that device appears on the status bar.

The right portion of the status bar displays the current state of the browsing operation.

Exploring the Scanlist Configuration Tool
The Scanlist Configuration Tool is an extension of the RSNetWorx software that allows 
you to create, modify, and delete connection entries within a scanlist (an EtherNet/IP 
scanner). Using the Scanlist Configuration Tool, you can establish connections among 
devices and their respective I/O components (identifying connection types, sizes, and 
timing intervals) and then map that information to the data table. The following 
illustration shows the Scanlist Configuration Tool window and the design elements 
associated with it. (The Message view will not be automatically shown in the default view, 
but may be chosen by selecting View > Messages > Show.)  Each of the design elements 
are described in the sections following this illustration.

Connection 
configuration

Title bar
Menu bar
Toolbar

Resource 
usage

Messages

Status bar
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Title bar
The title bar shows the Scanlist Configuration Tool icon, the name of the selected scanner, 
the name of the software product, i.e., Scanlist Configuration, and the Minimize, 
Maximize, and Close button.

For more information on the title bar, refer to the Exploring RSNetWorx for EtherNet/IP 
section in this chapter.

Menu bar
The Scanlist Configuration Tool menu bar contains the following menus:

Each menu contains options for performing the following tasks:

Menu Description

File Save a configuration, generate a report for this scanner, or exit the Scanlist 
Configuration Tool.

Edit Invoke actions such as cut, copy, and paste on selected items in the 
configuration.

View Set and change the Scanlist Configuration Tool interface displays.

Network Toggle between online and offline mode, and enable or cancel edits.

Device Change mode of the scanner from, for example, run to program mode or 
download to device.

Connection Insert connections or change connection parameters.

Help View help options for the Scanlist Configuration Tool and other Rockwell 
Software products and services.
14
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Online icon
The online icon displays in the right side of the Scanlist Configuration Tool at the same 
level as the menu bar.

This icon indicates whether or not RSNetWorx for EtherNet/IP is in the online mode. If 
you toggle the Online toolbar button to online, the Online icon becomes animated. If the 
icon is not animated, RSNetWorx for EtherNet/IP is in offline mode. When online, 
RSNetWorx for EtherNet/IP writes information to the devices and to the offline file when 
you save. When offline, RSNetWorx for EtherNet/IP only updates the offline file when 
you save.

Toolbar
The toolbars contain shortcuts to several commonly used functions. Each button on the 
toolbars is a graphical representation of a command that is  also available from the 
Scanlist Configuration Tool menu bar.

The following items appear on the Scanlist Configuration Tool toolbar:

Icon Menu Selection Description

File > Save Saves the current network configuration.

Edit > Cut Cuts the selected field value and places it on the 
clipboard.

Edit > Copy Copies the selected field value to the clipboard.

Edit > Paste Pastes the field value from the clipboard to the current 
network configuration.

Scanlist > Auto Insert > 
All Devices

Interrogates all devices that can have connections in the 
EtherNet/IP configuration and adds connections to the 
scanlist.

mp
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Resource usage
Within the Scanlist Configuration Tool, you can also view the memory usage.

Scanlist > Auto Insert > 
Selected Devices

Interrogates selected devices that can have connections 
in the EtherNet/IP configuration and adds connections to 
the scanlist.

Scanlist > Auto Address > 
All Entries

Auto maps all unmapped addresses in all entries.

View > Connection 
Configuration

Displays information respective to the selected 
connection.

View > Connection Status Switches the view to a display of the status of each 
connection.

Network > Online Places the Scanlist Configuration Tool in online mode. 
To go offline, click the button or choose Network > 
Online again. This button is unpressed when in online 
mode.

Help > What’s This? Places the cursor in What’s This? help mode. Place the 
cursor on the control you want help with and right-click 
to see the context-sensitive help.

Icon Menu Selection Description
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Scanlist entries
The scanlist entries enable you to perform tasks such as defining the connection targets 
and inserting connections for the selected devices.

Status bar
The status bar, which is located at the bottom of the Scanlist Configuration Tool window, 
provides information about the status of the software and the scanner.

The left portion of the status bar displays informational messages about the operation of 
the configuration software. For example, when you mouse over a toolbar icon, a brief 
description of that icon appears on the status bar.

The right portion of the status bar displays the following information:

 Online mode - Offline or Online
 Edit mode - Monitor or Edit
 Scanner type
 IP address/host name
 Scanner mode - Remote Idle, Idle, Remote Run, Run, or Offline
17
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Quick Start steps

The fastest way to configure your EtherNet/IP network is to specify an EtherNet/IP driver 
in RSLinx Classic and let the RSNetWorx for EtherNet/IP software browse your online 
network for EtherNet/IP devices and automatically add them into your configuration; and 
then, let the Scanlist Configuration Tool automatically configure connections to your 
target devices. You can follow this same procedure for configuring your network in the 
offline mode by manually dragging and dropping devices from your Hardware tab into 
your network configuration.

For some devices, you need additional RSLogix software to complete your  network 
configuration (for example, if you have ControlLogix processors on your network, then 
you must use RSLogix 5000 to complete your configuration).

This section walks you through the tasks you will need to perform to use RSNetWorx for 
EtherNet/IP software in both the online and offline modes. To remain focused on the high-
level nature of each task and on the flow of these tasks, the following steps do not include 
the step-by-step procedure for accomplishing each task. When you are ready to use 
RSNetWorx for EtherNet/IP software, you should follow the detailed procedures found in 
the Quick Start, which is located in the RSNetWorx for EtherNet/IP online help.

To access the software’s quick start, select Help > Quick Start from the RSNetWorx for 
EtherNet/IP window. To see information about any control on the RSNetWorx for 
EtherNet/IP or Scanlist Configuration Tool windows, remember to use the What’s This? 
help.

There is no offline mode when working with ControlLogix processors.  Also, for more 
information on using RSLogix 5000 and ControlLogix processors, refer to the online help 
for the Scanlist Configuration Tool.
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Online mode
Step 1 - Create a new configuration and browse for an online network

The first step in using RSNetWorx for EtherNet/IP in the online mode is to create a new 
EtherNet/IP configuration (File > New). Once you create the configuration, an empty 
network displays in the network configuration.

Next, go online and select an EtherNet/IP network using the RSWho Browse utility. A 
graphical representation of the selected network appears in the network configuration. If 
you would like to see a tabular view of the information instead of the graphical view, click 
the Spreadsheet tab.

Step 2 - Start the Scanlist Configuration Tool and insert a connection

The Scanlist Configuration Tool is a software tool used to create, modify, and delete 
scanlist entries in a scanner. This tool also allows you to define how particular devices 
communicate on the network. To configure devices that contain an internal scanlist, use 
the Scanlist Configuration Tool. Once you open the Scanlist Configuration Tool, you can 
either insert connections to other devices on the network manually, or you can use the auto 
insert feature within the Scanlist Configuration Tool to automatically insert the scanlist 
entries.

Step 3 - Define a connection target and save your network configuration

To provide data from the scanner to other devices on the network, you must define a 
connection target. You can define the connection target for the scanner IP address/host 
name on your network manually. After defining your connection targets, the final step is 
to save your network configuration and exit the Scanlist Configuration Tool.

Step 4 - Diagnose and troubleshoot your online network

Once you save your configuration, you can diagnose the network and determine the status 
of all of the devices on that network. If any of the devices are exhibiting diagnostics 
problems, you can troubleshoot those devices and return your network to proper operating 
condition.

These steps assume that you have configured a communication driver in RSLinx Classic 
for communication to the EtherNet/IP network.
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Offline mode
Step 1 - Create a new configuration and describe your network topology

The first step in using RSNetWorx for EtherNet/IP in the offline mode is to create a new 
EtherNet/IP configuration (File > New). Once you create the configuration, an empty 
network displays in the network configuration.

Next, you can describe your network topology by double-clicking on an available device 
or by dragging it from the Hardware tab and dropping it into the network configuration. 
When you are finished, a graphical representation of the selected network appears in the 
network configuration. If you would like to see a tabular view of the information instead 
of the graphical view, click the Spreadsheet tab.

Step 2 - Start the Scanlist Configuration Tool and insert a connection

The Scanlist Configuration Tool is a software tool used to create, modify, and delete 
scanlist entries in a scanner. This tool also allows you to define how particular devices 
communicate on the network. To configure devices that support the open standard for 
EtherNet/IP scanners, use the Scanlist Configuration Tool. Once you open the Scanlist 
Configuration Tool, you can either insert connections for the scanner IP addresses/host 
names on your network manually, or you can use the auto insert feature within the Scanlist 
Configuration Tool to automatically insert the scanlist entries.

Step 3 - Define a connection target and save your schedule

To provide data from the scanner to other devices on the network, you must define a 
connection target. You can define the connection target device for the scanner IP 
address/host name on your network manually. After defining your connection targets, the 
final step is to save your configuration and exit the Scanlist Configuration Tool.
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2 Installing and Starting RSNetWorx for 
EtherNet/IP

This chapter explains how to install and start RSNetWorx™ for EtherNet/IP™ software. 
This chapter includes information on the following:

 system requirements
 software compatibility
 installation methods
 installation procedure
 starting procedure
 troubleshooting

After installing the software, we recommend that you read the release notes located in the 
online help. The release notes may contain more up-to-date information than was 
available when this document was published. To view the release notes, start RSNetWorx 
for EtherNet/IP, and then choose Help > Release Notes from the main menu.

Before You Begin

Rockwell Software uses a software key to implement copy protection for Windows-based 
software products. Every software product has a unique key.  Although, you can install the 
software on any number of computers, you are only licensed to run the software on one 
computer at a time. After you install the RSNetWorx software, the Setup program will 
prompt you to activate your software. For more information about moving software keys, 
copy protection, and software activation, refer to Appendix A in this guide.

System requirements

To run RSNetWorx for EtherNet/IP, your system must meet the following hardware and 
software requirements:

Hardware requirements
To run RSNetWorx for EtherNet/IP, your system must meet the following hardware 
requirements:

 an Intel Pentium™ 4 processor (2.4 GHz or faster)
 1 GB of RAM; more memory is required for large networks 
 16 GB of maximum disk space (EDS files take 20.2 MB). These sizes are based on a 

Microsoft FAT file system. A Microsoft NTFS file system will use much less space. 
 True Color VGA graphics device with a minimum resolution of 1024 x 768
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 a DVD-ROM drive

 a mouse or other Windows compatible pointing device is recommended

Software requirements
To run RSNetWorx for EtherNet/IP, you require one of the following operating systems:

 Windows 8.x
 Windows 7 Professional with Service Pack 1 and Windows 7 Home Premium with 

Service Pack 1
 Windows Server 2012 Standard
 Windows Server 2012 R2
 Windows Server 2008 Standard with Service Pack 2
 Windows Server 2008 R2 Standard with Service Pack 1

Software Compatibility

RSNetWorx for EtherNet/IP v25 is a component aligned to Studio 5000 Logix Designer™ 
v28. This version of RSNetWorx for EtherNet/IP has been tested with, and is compatible 
with the following products:

 FactoryTalk Activation Manager (version 3.62)
 FactoryTalk Services Platform (version 2.80)
 RSLinx Classic (version 3.80)
 RSLogix 5 (version 8.00)
 RSLogix 5000 (version 28.00)

It is recommended that you use all products from the same CPR release.
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Installing RSNetWorx for EtherNet/IP software

You can install one or more Rockwell Software products on a single personal computer. 
Select the required Rockwell Software product and each required component for 
installation.

To install RSNetWorx for EtherNet/IP software, perform the following steps:

1. Start your operating system if it does not start automatically.

2. Insert the RSNetWorx for EtherNet/IP DVD-ROM into the DVD-ROM drive.

3. In the Product Selection page, select RSNetWorx for EtherNet checkbox, and Click 
Next.

You can click View Release Notes for Selected Product to ensure your system meets 
the minimum requirements, and to learn about new features included with this 
version.

4. In the Customer Information page, enter the user name and organization, and click 
Next.

5. In the License Agreement page, read the end-user license agreement, select I accept 
the terms in the license agreement, and click Next.

While installing RSNetWorx for EtherNet/IP software, you will have the opportunity to 
specify a directory. The suggested default directory is:

x:\Program Files\Rockwell Software\RSNetWorxII

where x is the drive where the operating system is installed.

We recommend that you use the default directory whenever possible. This subdirectory 
contains all of the application files required to run the product.

In procedures that appear throughout this document, it is assumed that you used the 
default name. If you did not use the default name, substitute the actual name you specified 
for the default name shown.

If autorun is: Then:

enabled The installation program starts automatically and the selection dialog 
box appears. Proceed to step 3.

disabled Perform the following steps:

Click Start, and then click Run. The Run dialog box appears.

In the Open field, type x:\setup.exe, where x is the letter of the drive 
containing the RSNetWorx for EtherNet/IP CD-ROM.

Click OK. The selection dialog box appears.
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6. In the Installation Location page, click Next. You can also click Change to select 
another location.

7. In the Feature Selection page, select the approriate installation type and click Next.

8. In the Configuration Summary page, review the information. If the information is 
correct, click Install to continue.

9. When the installation completes, 

 To activate RSNetWorx, select the Activate products check box.

 To set up security in RSNetWorx, select Enable FactoryTalk Security and select 
the FactoryTalk directory that will be used to authenticate and authorize user 
access. 

10. Click Finish to exit.

Installing a client copy from a dedicated server
As a client to a client-server installation, you can install one or more Rockwell Software 
products from the dedicated server location to an end-user destination. To install the 
RSNetWorx for EtherNet/IP software from the server, perform the following steps:

1. Map a network drive to the dedicated server location provided by your system 
administrator. The system administrator must have copied the entire DVDcontents and 
provided only Read and Execute permissions of the files. Users installing the software 
cannot have write access to the files.

2. Double-click autorun.exe in the client installation directory.

3. See the “Installing RSNetWorx for EtherNet/IP software” section in this chapter.

Starting RSNetWorx for EtherNet/IP software

To start RSNetWorx for EtherNet/IP software, click Start, and then select Programs > 
Rockwell Software > RSNetWorx (folder) > RSNetWorx for EtherNet-IP (executable) 
from the Start menu.

To create a desktop icon, click Start, and then select Programs > Rockwell Software > 
RSNetWorx for EtherNet-IP shortcuts, and drag the RSNetWorx for EtherNet/IP 
shortcut to the location of your choice.

We assume that you used the default names for the directory and program group. If you did 
not use the default names, substitute the actual names that you specified for the default 
names shown.
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Troubleshooting installation

If RSNetWorx for EtherNet/IP does not start up or run properly, consider the following:

 Do you have the correct version of RSLinx Classic installed? RSNetWorx for 
EtherNet/IP requires the RSLinx Lite 2.4 (or later) release.

 Does your computer have enough memory? Running RSNetWorx for  EtherNet/IP 
requires a minimum of 32 MB of RAM.

 Have you reinstalled an earlier Service Pack, or removed a component, such as 
DCOM, that RSNetWorx for EtherNet/IP requires?

 Have you checked the RSNetWorx support on the web for troubleshooting 
information? Go to http://www.rockwellautomation.com/support, click 
Knowledgebase, and search for Tech Notes on RSNetWorx for EtherNet/IP.
25
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3 Advanced Concepts

This chapter contains the following sections:

 EDS-based devices
 EDS library
 Class Instance Editor

EDS-based devices

RSNetworx for EtherNet/IPTM relies on an electronic data sheet (EDS) for configuring 
devices.  An electronic data sheet is an ASCII file that is created by the manufacturer and 
supplied with the device.

As long as the EDS file for the device you want to configure is registered with the 
RSNetWorx for EtherNet/IP software, you can configure its target connection 
configuration (attributes) and how it will communicate with other devices on the 
EtherNet/IP network. Although the procedure for configuring a device is basically the 
same for all devices, each device has a unique set of properties.

EDS library

The electronic data sheet (EDS) library is a collection of EDS files that have been 
registered with RSNetWorx for EtherNet/IP. The EDS files, which are provided by the 
device manufacturers, contain configuration and identification information for the 
devices.

RSNetWorx for EtherNet/IP software can access only those devices that have been 
registered. You must use the EDS Registry Wizard for registering EDS files for unknown 
devices, or if you have updated EDS files to install.  To access the EDS Wizard, select 
Tools > EDS Wizard.
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Although you get a large number of electronic data sheet (EDS) files with the RSNetWorx 
for EtherNet/IP software, there may be a time when you need to acquire/create additional 
EDS files. The most common ways to get these files are to:

 obtain them on distribution diskettes that accompany the devices.
 download them from EtherNet/IP sites on the world wide web. You can either select 

the device in the network configuration, right-click the mouse and select Re-register 
Device, and click Download EDS File in the EDS Wizard or access one of the 
following world wide web sites from which EDS files are available:
 http://www.ethernet-ip.org (EtherNet/IP International web site)
 http://www.ab.com/networks/eds (Allen-Bradley technical support site)

 download them from a different manufacturer’s site.

Class Instance Editor

The Class Instance Editor is a tool that allows you to send data to, and read data from, an 
EtherNet/IP device that is not otherwise configurable with RSNetWorx for EtherNet/IP. 
Using the Class Instance Editor, you can either enter raw data and download it to the 
device, or read the data from the device.

To use the editor, you will need to know the service code, class, instance, and attribute by 
their appropriate hexadecimal codes within the device. This information may be on the 
printed data sheet accompanying the device.

We do not recommend configuring devices with the Class Instance Editor unless you are 
instructed to do so by technical support personnel for the hardware product.

For further information about configuring a device with the Class Instance Editor, contact 
the manufacturer of the device. For more information on how to enter data into the Class 
Instance Editor, contact Rockwell Software technical support.
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4 Finding the Information You Need

This chapter describes how to:

 Use the online help
 Access product manuals
 Complete the product tutorial
 Participate in Rockwell Software training courses
 Contact technical support

Using the online help

RSNetWorx for EtherNet/IPTM online help provides general overview information, 
comprehensive step-by-step procedures, and context-sensitive, dialog box control 
definitions for working with all of the features in the software. To view online help while 
running RSNetWorx for EtherNet/IP:

 choose Contents from the Help menu on the RSNetWorx for EtherNet/IP main 
window

 click Help on any RSNetWorx for EtherNet/IP dialog box or property page
 position the cursor over a control with which you want help and right-click
 press F1
 click the What’s This? icon located in the toolbar or in the upper right corner of dialog 

boxes, then click any control
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Accessing help for a control or field
 To display a definition for a control or a field, click the What’s This? icon in the upper 
right corner of the dialog box, drag the cursor to the selected area, and then click to 
display the definition. You can also right-click on a control to display the definition. In 
this example, the PanelView properties page was selected.
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Accessing help for messages
The Message view, which appears in the bottom portion of the workspace, displays a log 
of messages. This view may contain informational, warning, and/or error messages.

To troubleshoot a particular message, you can select the message and press the F1 key or 
right-click on the message and select Troubleshoot to access the online help. For 
example, if you select the ENET:8282 message code shown here and press F1, the “The 
online scanlist in address 192.168.1.6 does not match its scanlist in the offline file” 
troubleshooting help topic displays.

From the message view, you can also select a message and choose View > Messages > 
Troubleshoot to display online help for the message. You can also show, clear, and/or 
clear and hide messages by making the appropriate selection from the View > Messages 
command on the main menu. The copy menu item copies the selected message to the 
Windows clipboard so it can be pasted into other applications (for example, an e-mail 
message).

m
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Finding step-by-step procedures
To view a list of tasks related to the task-based topic, move to the What do you want to 
do? section at the bottom of the help window and select one of the listed tasks. The 
contents pane of the help window is updated, displaying a step by step procedure for 
completing the selected task.

For example, from the Define or Edit a chassis help topic, if you select Change a device’s 
slot position under the What do you want to do? section, the help topic that describes how 
to change a device’s slot position replaces the original help topic. Also, in the Change a 
device’s slot position help topic, How do I access the dialog? is a drop down navigational 
tip.
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Finding definitions
Within the RSNetWorx for EtherNet/IP help, blue highlighted text with an underline 
indicates a pop-up definition or a link to a related topic. For example:
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Accessing the Product Manuals

You can gain immediate access to product documentation through the Online Books 
feature in RSNetWorx for EtherNet/IP. Product Manuals includes this Getting Results 
Guide, as well as many reference guides, in an electronic book format. Select Help > 
Product Manuals to access this documentation.

Tutorial

RSNetWorx for EtherNet/IP contains a product tutorial, which includes basic overview 
information and specific tasks and examples for successfully working with the product. 
This tutorial is available from Start > Programs > Rockwell Software > RSNetWorx > 
RSNetWorx for EtherNet-IP Tutorial.
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Training

One of the best ways to increase your proficiency at using Rockwell Software products is 
to attend a Rockwell Software training program. Our training programs can help you 
master the basics and show you how to unleash the full potential of our software.

We offer a wide range of training programs, from regularly scheduled classes conducted at 
Rockwell Software facilities, to custom-tailored classes conducted at your enterprise. The 
size of each class is kept small intentionally to maximize student engagement.

If you would like more information about our training programs, visit the Rockwell 
Software site on the World Wide Web or contact the Rockwell Software Training 
Coordinator. Our World Wide Web address and telephone numbers appear on the inside 
front cover of this document.

Technical support

If you cannot find answers to your questions in the Getting Results with RSNetWorx for 
EtherNet/IP guide, the online help, or the Online Books documentation, you can call 
Rockwell Software Technical Support at the numbers listed on the inside front cover of 
this guide.

When you call
When you call, you should be at your computer and prepared to give the following 
information:

 product serial number and product version number
 The product serial numbers and version number can be found in the software by 

selecting Help > About RSNetWorx
 hardware you are using
 operating system plus service packs, and version of Internet Explorer (if any) installed
 exact wording of any errors or messages that appeared on your screen
 description of what happened and what you were doing when the problem occurred
 description of how you attempted to solve the problem

For more information on Rockwell Software training, go to the Training Services web site: 
http://www.rockwellautomation.com/services/training/

For more information on Rockwell Software training, go to the Services & Support web 
site: http://www.rockwellautomation.com/services/
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RSNetWorx for EtherNet/IP supports only FactoryTalk activation.

If you are a new user, you will need to activate your software using FactoryTalk 
Activation because RSNetWorx no longer ships with a physical master disk for activating 
software. For more information, read the “Activate RSNetWorx with FactoryTalk 
Activation” section of this appendix. 

Activate RSNetWorx with FactoryTalk Activation

RSNetWorx for EtherNet/IP supports the following types of activation:

Node-locked activation
This type of activation can be either locked to a particular piece of hardware, such as an 
EtherNet card or a harddisk of a stand-alone computer, or to a hardware dongle. 
Depending upon the kind of device (stand-alone computer or hardware dongle) you want 
to activate, you can purchase either

 Local “node-locked” activation: This kind of activation activates software only on a 
single computer. If the activation file is copied to another computer, the software will 
not run on that other computer, or

 Mobile “node-locked” activation: This kind of activation is locked to hardware 
dongle. A dongle is a security or copy protection device that must be connected to the 
computer while the program runs. The activation files can be copied to multiple 
computers, but the software activates only on the computer where the dongle is 
connected.

Concurrent activation
This type of activation allows multiple computers across a network to use Rockwell 
Software products at the same time. There are two kinds of concurrent activations:

 Floating activations: activations that “float” from an activation server to any computer 
that needs them.

 Borrowed activations: activations that are retrieved from a server for a specific period 
of time before expiring and returning automatically to the pool of available activations 
on the server. 

How to activate RSNetWorx
To activate your copy of RSNetWorx, perform the following steps: 
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1. Install the FactoryTalk Activation Client available from the Optional Steps screen of 
the Install program. 

2. Once FactoryTalk Activation Client is installed, it will load the FactoryTalk 
Activation Wizard which will guide you through the steps of downloading the 
activation from the Internet. You can download the activation to your stand-alone 
computer or hardware dongle. 

Finding more information about FactoryTalk Activation
For help with FactoryTalk Activation at any point, you can click:

 the Help button on any FactoryTalk Activation Tool dialog or FactoryTalk Activation 
Transfer Tool dialog

 the Help link on the Rockwell Software Activation website: 
http://licensing.software.rockwell.com

 View How to Activate Rockwell Software Products on the Required Steps of the 
Install program

If you cannot connect to the Internet, call Technical Support for help creating an 
activation file from an e-mail or a fax. 

Phone:  440-646-3434 in North America. Outside of North America, call your local 
support organization.

Grace period
In RSNetWorx for EtherNet/IP v9.00.00 (CPR 9 Service Release 1) and later, the software 
supports a seven day activation grace period when a valid activation is not found. During 
grace period:

 If RSNetWorx is started and an activation key is not present, the software shall enter 
grace period and run with full functionality.

 Once RSNetWorx has entered grace period, the software shall check for an activation 
key every four hours. If the activation is not found, a message will be generated to 
FactoryTalk Diagnostics. 

 RSNetWorx can be started an unlimited number of times while in grace period and be 
able to run with full functionality. If the grace period ends and a valid activation has 
not been found, RSNetWorx shall run in Demo mode. 

 While RSNetWorx is running, the software cannot change modes. RSNetWorx can 
only change to Demo mode when the software is restarted and/or grace period has 
already expired.

If RSNetWorx is unable to successfully obtain valid activations (for example, a network 
failure occurs), the software will attempt run in grace period for up to seven days. 
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Some common questions
Following are some common problems that people encounter with activation and their 
solutions.

MY ACTIVATION FILES WERE DAMAGED. WHAT SHOULD I DO?

If you have lost the activation because the activation file is damaged, you need to reset 
activation. Follow the Reset Codes instructions on the Rockwell Software Technical 
Support web page, or call the technical support telephone number. The web page and 
telephone number are both listed on the inside front cover of this guide.

I ACCIDENTALLY DELETED THE SOFTWARE DIRECTORY ON MY HARD DRIVE. 
DO I NEED TO CALL ROCKWELL SOFTWARE FOR REPLACEMENT 
ACTIVATION FILES?

No. Deleting the program files does not delete your activation. The activation files are not 
stored in the program directory; they are located in the root directory. Your activation files 
will not be lost unless you format the hard drive, tamper with hidden files in the root 
directory, or perform certain other hard drive operations (refer to the “Protecting your 
activation files” section in this chapter for more information).

To get the software running again, simply reinstall the software, but do not move the 
activation when given the opportunity.

Finding more information about activation
The online help (COPYPROT.HLP) provides more extensive information on activation 
including subjects such as:

CHECKDRIVES. Specify which drives to search for activation

network activation. Move activation to a network server to allow multiple users access to 
the activation

moving activation. See detailed instructions for moving activation

resetting activation. See detailed instructions for using the Reset utility to repair a 
damaged activation file

troubleshooting. Look up error messages, get problem-solving suggestions

You can access online help:

 from the Help button on one of the EvMove or Reset dialog boxes.
 from RSNetWorx by selecting Help > Copy Protection from the main menu.
 without running either RSNetWorx or the activation utilities. From the Windows Start 

menu, select Programs > Rockwell Software > Utilities > Activation Help (if you 
accepted the default directory location during installation).
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FactoryTalk Security™ is intended to improve the security of your automation system by 
limiting access to those with a legitimate need. FactoryTalk Security authenticates user 
identities and authorizes user requests to access a FactoryTalk-enabled system. These 
security services are fully integrated into the FactoryTalk Directory and are included as 
part of the FactoryTalk Services Platform that installs with many products.

For more information on how to use security services, refer to FactoryTalk Security’s 
Online help.

How do I set up security in RSNetWorx?

RSNetWorx supports FactoryTalk Security. FactoryTalk Security™ is intended to 
improve the security of your automation system by limiting access to those with a 
legitimate need. FactoryTalk Security authenticates the identities of users and authorizes 
user requests to access a FactoryTalk-enabled system against a set of defined user 
accounts and access privileges held in the FactoryTalk Directory. For more information on 
FactoryTalk Security, refer to the ‘About FactoryTalk Security’ topic in RSNetWorx for 
EtherNet/IP Online Help

Follow the steps below to set up security in RSNetWorx:

1. Install FactoryTalk Services Platform from RSNetWorx Optional Steps Install screen. 
(Following the install, open the FactoryTalk Administration Console and configure 
the FactoryTalk Directory that you want to use.) 

2. Install RSNetWorx from RSNetWorx Required Steps Install screen.

For more information on FactoryTalk, FactoryTalk Automation Platform, FactoryTalk 
Administration Console, and FactoryTalk Directory, refer to the Glossary.
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3. While running RSNetWorx’s installation wizard, you will see the Enable Security and 
Select a FactoryTalk Directory install screen.  On this screen, select the ‘Enable 
security’ option. And then select the FactoryTalk directory (Network or Local) that 
will be used to authenticate and authorize user access

.

4. Click Next, and then click Install to continue the RSNetWorx installation.

5. When the install is complete, click Finish.
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What can I secure in RSNetWorx?

RSNetWorx implements FactoryTalk Security through three securable actions: Access, 
Modify, and Go Online. These securable actions let you restrict user access to actions, 
such as opening a project file, creating a new project file, making changes to a project file, 
uploading or downloading to a device, browsing to a device from the network, viewing 
the properties of a device, etc., in RSNetWorx. 

Securable action Description

Access The Access securable action allows you to perform actions 
such as opening an offline project file for viewing, viewing 
the properties of a device, etc.

Modify The Modify securable action allows you to perform actions 
such as creating a project file, making changes to a project 
file, saving any pending edits, etc.

Note: To modify a project file, you need both Access (to open the 
file) and Modify (to make changes) securable actions.

Go Online The Go Online securable action allows you to download 
information saved in a project file or upload information 
into a project file, as well as browse to a device on the 
network.

Note: 

 To download information saved in an existing project file, you 
need Access (to open the file), Go Online (to go online to 
prepare to download), and Modify (to download) securable 
actions.

 To upload information into an existing project file, you need 
Access (to open the file), Go Online (to go online to prepare to 
upload), and Modify (to upload) securable actions.

 To upload information into a new project file, you need Go 
Online (to go online to upload) securable action.
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To allow or deny user access to one or more of the above securable actions, you will need 
to:

1. Start FactoryTalk Administration Console from Start > Programs > Rockwell 
Software > FactoryTalk Administration Console. You will see the Log On to 
FactoryTalk screen, as shown below.

2. Enter your username and password, and select the directory you want to log on to. 
(The username and password were set when you set up an account during FactoryTalk 
Directory configuration.)

Tips for choosing a directory: 

 Click Network to access Network (also called Distributed) applications on the 
Network Directory Server.

 Click Local to access Local (also called Stand-alone) applications on the Local 
Directory. Local applications are always located on your local computer. You 
cannot access local applications remotely.

 If you cannot log on to a particular directory on your computer, it may be because 
it has not yet been configured. For more information, refer to the Right 
FactoryTalk Directory is not configured on this computer topic in FactoryTalk 
help. You can launch FactoryTalk Help from FactoryTalk Administration Console.
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3. In FactoryTalk Administration Console, click on the RSNetWorx folder (located 
under System > Policies > Product Policies), to expand it. You will see the Feature 
Security file. 

4. Double-click the Feature Security file to launch the Feature Security Properties dialog 
box.  

5. In the Feature Security Properties dialog box, click the securable action you want to 
grant the user access to.

6. In the Configure Securable Action dialog box, from the list of users, select the user 
you want to grant access to, and click Add. 

For more information on FactoryTalk and FactoryTalk Security, refer to RSNetWorx for 
EtherNet/IP Online Help.
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Activation file — A hidden, read-only, system file that “activates” a Rockwell Software 
product. The software will run only if your system can find the correct activation file.

Activation key — Activation files contain a database of activation keys. Each key is 
particular to a certain product and must be accessible on a local or remote drive for that 
product to run.

Bridge — A multi-port device that connects network segments that use different physical 
media. Bridges also monitor network traffic, building and maintaining internal tables that 
list the port on which each Ethernet address resides. When a bridge receives a packet 
destined for a particular address, the bridge transmits the packet again only on the port at 
which the device resides. Each port on a bridge represents a separate collision domain. 

Connection — An open, logically binding communication path between two devices on a 
EtherNet/IP network.  Connections can be either point to point or multicast connection.

Connection ID — An identifier assigned to a particular connection between producers 
and consumers that specifies select application information.

Connection type — The connection type indicates the data ownership of a node. It 
defines the rule for how the connection entry controls outputs to the rack, module, or 
device. The following are standard connection types:

 Exclusive Owner - specifies an independent connection where a single device 
controls the output states in the target device. If you have an existing Exclusive Owner 
connection to a target device, you cannot specify another Exclusive Owner or 
Redundant connection to that same target device.

 Input Only - specifies an independent connection where a device receives inputs 
from the target device and sends configuration data to the network. An Input Only 
connection does not send outputs; it only receives inputs. You can specify multiple 
Input Only connections to the target device from different originators.
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 Listen Only - specifies a dependent connection where a device receives  inputs from 
the target device, but does not send configuration data with the network. A Listen 
Only connection only functions properly when another non-Listen Only connection 
exists to the same target device. A Listen Only connection does not send outputs; it 
only receives inputs. You can specify multiple Listen Only connections to the target 
device from different originators.

Consumer — A node that receives data from a producer on a EtherNet/IP link.

Cut-through switching — Cut-through switching starts sending packets as soon as they 
enter a switch and their destination address is read. The entire frame is not received before 
a switch begins forwarding it to the destination port. This reduces transmission latency 
between ports, but it can propagate bad packets and broadcast storms to the destination 
port.

EtherNet/IP network — An industrial automation network standard that is sponsored by 
EtherNet/IP International.

FactoryTalk is a manufacturing information platform that integrates plant-wide control 
systems and connects the enterprise with the production facility.

The FactoryTalk Automation Platform:

 provides common services (such as diagnostic messages and access to real-time data) 
and shares plant resources (such as tags and graphic displays) throughout a production 
facility

 allows defining plant-floor resources once, and then allows simultaneous access to 
those resources across product boundaries

 supports centralized security services

FactoryTalk Administration Console — Part of the FactoryTalk Automation Platform, 
FactoryTalk Administration Console is an optional, stand-alone tool that allows you to:

 Create and configure application, area, and data server elements in the FactoryTalk 
Directory.

 Back up and restore an entire directory or an individual application.

 Set up redundancy for OPC data servers.

 Configure client computers to recognize the location of a FactoryTalk Directory 
Server computer.

 Configure options for routing and logging diagnostic messages.

All Listen Only connections will be terminated when all non-Listen Only connections are 
terminated.
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 View system-wide diagnostic messages.

 Configure system-wide policy settings.

 Secure your FactoryTalk-enabled system with FactoryTalk Security™ services.

Run FactoryTalk Administration Console from the Windows Start menu: Start > 
Programs > Rockwell Software > FactoryTalk Administration Console.

FactoryTalk Directory — FactoryTalk Directory provides a central lookup service for 
software products participating in a FactoryTalk-enabled automation system.

The FactoryTalk Automation Platform includes two separate directories: a Local 
Directory and a Network Directory. Either directory, or both directories, can be 
configured on the same computer. Project information, including security settings, cannot 
be shared between a Local Directory and Network Directory, even if both directories are 
configured on the same computer. Create and configure application, area, and data server 
elements in the FactoryTalk Directory.

 Local Directory — all project information and participating software products are 
located on a single computer, and the FactoryTalk-enabled system cannot be shared 
across a network or accessed remotely. 

 Network Directory — organizes project information from multiple software products 
across multiple computers on a network. 

Some FactoryTalk-enabled products require a Network directory, others require only a 
Local directory, and some require that both directories be configured.

Gateway — The term gateway has many different meanings.  For example: a device that 
performs protocol conversion between different types of networks or applications.  Such 
gateway function at the transport layer and above. They perform complete conversions 
from one protocol to another rather than simply supporting one protocol from within 
another.  Sometimes router can implement such gateway functions; and a device that acts 
as a go-between connecting two or more networks that use the same protocols.  In this 
case, the gateway functions as an entry/exit point to the network.  Transport protocol 
conversion may not be required, but some form of processing is typically performed. 

Hub — A hub is a common wiring point for star-topology networks. Hubs have multiple 
ports to attach the different cable runs. Some hubs include electronics to generate and time 
the signal between each hub port. Others act as signal splitters, similar to the multi-tap 
cable-TV splitters you might use on your antenna coax. Some route the network signals to 
each active device in series, while other hubs distribute received signals out all ports 
simultaneously.
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Internet Group Management Protocol (IGMP) snooping — This protocol constrains 
the flooding of IP multicast traffic by dynamically configuring the switch interfaces so 
that multicast traffic is forwarded only to those interfaces associated with IP multicast 
devices.

License — Authorization to use a specified number of instances of software. A product’s 
activation key contains a license for each copy of the software you have purchased. For 
example, if you bought seven copies of RSLogix 5, then the RSLogix 5 key on the Master 
Disk contains seven “licenses” of RSLogix 5. You can move an activation key for 
RSLogix 5 to seven different computers.

Master disk — This disk is supplied with the software. It contains a database of keys in 
an “activation file” that enables the software to run. Be sure to store your Master Disk in a 
safe place. If your activation file becomes damaged, the only way you can run your 
software (until the activation is reset) is with your Master Disk.

Multicast connection — A connection made from one node to many nodes. Multi-cast 
connections allow multiple consumer nodes the ability to receive data from a single 
producer node.

Node — A node is a EtherNet/IP address. When a device is added to the network, it is 
assigned a node address..

Offline Configuration File — In RSNetWorx for EtherNet/IP,  the offline configuration 
file (*.enet) contains network configuration information (including scanlist data, device 
and chassis definitions, rack size and density, etc.).  When online, the download operation 
applies all of the offline configuration information to the online network and the upload 
operation applies all of the network configuration information obtained from the online 
network to the offline configuration file. 

Point-to-point connection — A connection made between two nodes only.

Producer — A node that is responsible for transmitting data on a EtherNet/IP link.

Requested Packet Interval — The requested packet interval (RPI) value is determined 
by how often you want a particular piece of I/O or scheduled peer-to-peer data to be 
transmitted within the scheduled bandwidth of the NUI. 

Router — A router is a device that forwards traffic between networks based on the 
network layer information in the data and on the routing tables that it maintains. The 
router builds up a logical picture of the overall network in its routing tables, and then uses 
this information to choose the best path for forwarding network traffic.

Scanlist Configuration Tool (SCT) — A program that maps processor memory onto the 
network and network data into processor memory. SCTs are scanner-specific; therefore, a 
unique SCT is required for each type of scanner.
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Scanner — A EtherNet/IP device that is a connection originator.

Scanner class device — A device that initiates connections and contains a scanlist. Refer 
to the RSNetWorx for EtherNet/IP online tutorial for more information.

Scanner signature — Indicates a hexadecimal value, unique to the open scanner, that is 
assigned to scanner devices that originate scheduled connections. This value is stored in 
the open scanner and in the offline configuration, and is used to determine if the offline 
configuration is synchronized.

Segment — A section of a local area network (LAN) that is used by a particular 
workgroup or department and separated from the rest of the LAN by a bridge, router, or 
switch.  Networks are divided into multiple segments for  security and to improve traffic 
flow by filtering out packets that are not destined for the segment.  

Switch — A switch evolved from the bridge.  Like traditional bridges, switches build and 
maintain internal tables that map Ethernet addresses to a port.  A packet received on one 
port is rapidly switched to the appropriate output port (typically within microseconds).  
Each port on the switch is its own collision domain, so collisions between devices 
attached to the switch do not occur.

A switch segments a network into many parallel dedicated lines to produce a contention-
less, scalable architecture.  The switch establishes a direct line of communication between 
two ports and maintains multiple simultaneous links between various ports.  The switch 
uses addressing information in each Ethernet frame to forward data only to the port 
connected to the destination device.  The switch manages network traffic by reducing 
media sharing since the traffic is directed only to the segment for which it is destined.   

There are two basic methods of switching: cut-through and store-and-forward.

Store and forward switch — Store-and-forward switching buffers incoming packets in 
memory until they are fully received and a cyclic redundancy check (CRC) is performed. 
This reduces bad packets and collisions that can adversely effect the overall performance 
of the segment. However, the buffering adds latency to the processing time. The latency 
increases in proportion to the frame size.

Cut-through switch — Cut-through switching starts sending packets as soon as they 
enter a switch and their destination address is read. The entire frame is not received before 
a switch begins forwarding it to the destination port. This reduces transmission latency 
between ports, but it can propagate bad packets and broadcast storms to the destination 
port.
51



RSNETWORX FOR ETHERNET/IP GETTING RESULTS GUIDE
• 

 •
  •

  •
  •
52



 Index 
Index

A
activation  37,  41

EVRSI
damaged  39
network  39
resetting  39
troubleshooting  39

FactoryTalk
activate  37

file  47
key  47

adding a device  9
auto insert devices  15
auto map entries  16

C
CHECKDRIVES  39
Class Instance Editor  28
classes, training  35
clearing messages  31
close  5
communication service  2
configuring

devices  27
connection  47
connection configuration  16
connection ID  47
connection settings  17
connection status  16
connection type  47
consumer  48,  50
context-sensitive help  2,  7,  16,  29
control definitions  29
Control menu  5
ControlNet concepts  3
copy protection  41
copying

devices  7,  15
messages  31

creating a network configuration  7

cut-through switching  48
cutting devices  7,  15

D
DCOM  25
definitions  33
deleting the software directory  40
design elements  4
device

adding  9
comparison states  8
configuring  27

diagnostics  8
document conventions  iv
documentation set  iii
download  2

E
edits enabled  8
EDS

devices  27
library  27
Registry Wizard  27

electronic book format  iv,  34
email correspondence  iv
error messages  12
exploring RSNetWorx for ControlNet  4,  13

F
FactoryTalk  41,  48
FactoryTalk Activation  37
FactoryTalk Administration Console  44,  48
FactoryTalk Automation Platform  48
FactoryTalk Directory  41,  42,  49
FactoryTalk Security  41
FactoryTalk Services Platform  41
features and benefits  1
feedback  iv
finding available networks  8
59



RSNETWORX FOR ETHERNET/IP GETTING RESULTS GUIDE
• 

 •
  •

  •
  •
G
grace period  38
graph view  9

H
hardware devices

available  8
diagnostics  8
favorite  8

hardware requirements  21
hiding messages  31
HTML reports  2

I
I/O data  2
informational messages  12
installation  21,  23

existing  24
intended audience  iii

L
license  50
listing hardware devices

available  8
favorites  8

Local Directory  49

M
master disk  50
maximize  5
menu bar  6
message codes  12
messages  31

clearing  31
copying  31
hiding  31
information  13,  17
view  12

minimize  5
move  5
multicast connection  50

N
network

opening a configuration  7
Network Directory  49
network EVRSI activation  39
network update interval  50
node  50

O
offline  2
online  2,  8,  16
online help  iii,  29
opening a network configuration  7

P
pasting devices  7,  15
PCSC  50
PDF files  iv
peer-to-peer data  2
point-to-point connection  50
printing a network configuration  7
producer  50
product manuals  iii,  34

Q
quick start  18

R
RAM  21
redundant  50
refresh tree and diagram  8
release notes  iii
resetting EVRSI activation  39
resource usage  16
restore  5
RSLinx  iii
RSNetWorx icon  5

S
saving a network configuration  7,  15
scanner  51
scanner class device  51
scanner signature  51
60



 INDEX
•  •  •  •  •

Index
scheduled bandwidth  50,  51
scheduled node  50
SCT  50
Securable action  43
size  5
software compatibility  21,  22
software requirements  22
spreadsheet view  9
status bar  13,  17
step-by-step procedures  29
Store and forward switch  51
symbol legend  8
system compatibility  22
system requirements  21

T
tasks  32
technical support  35
telephone number  35
title bar  5,  14

training  35
troubleshooting  31

EVRSI activation  39
installation  25

tutorial  iv,  34

U
unscheduled node  50
upload  2

W
warning messages  12
Web address  35
What’s This? help  30

Z
zoom selection

zoom in  8
zoom out  8
61



RSNETWORX FOR ETHERNET/IP GETTING RESULTS GUIDE
• 

 •
  •

  •
  •
62


	Preface
	Purpose of this document
	Intended audience
	How does the Getting Results Guide fit in with other Rockwell Software product documentation?
	Online help
	Product Manuals

	Tutorial
	Document conventions
	Feedback

	Contents
	Welcome to RSNetWorx for EtherNet/IP
	Features and benefits
	Understanding EtherNet/IP concepts
	Exploring RSNetWorx for EtherNet/IP
	Title bar
	Menu bar
	Online icon
	Toolbars
	Edits enabled
	Hardware and Favorites views
	Graph or Spreadsheet view
	Diagnostics view
	Message view
	Status bar
	Exploring the Scanlist Configuration Tool
	Title bar
	Menu bar
	Online icon
	Toolbar
	Resource usage
	Scanlist entries
	Status bar

	Quick Start steps
	Online mode
	Offline mode


	Installing and Starting RSNetWorx for EtherNet/IP
	Before You Begin
	System requirements
	Hardware requirements
	Software requirements

	Software Compatibility
	Installing RSNetWorx for EtherNet/IP software
	Installing a client copy from a dedicated server

	Starting RSNetWorx for EtherNet/IP software
	Troubleshooting installation

	Advanced Concepts
	EDS-based devices
	EDS library
	Class Instance Editor

	Finding the Information You Need
	Using the online help
	Accessing help for a control or field
	Accessing help for messages
	Finding step-by-step procedures
	Finding definitions

	Accessing the Product Manuals
	Tutorial
	Training
	Technical support
	When you call


	Activation
	Activate RSNetWorx with FactoryTalk Activation
	Node-locked activation
	Concurrent activation
	How to activate RSNetWorx
	Finding more information about FactoryTalk Activation
	Grace period
	Some common questions
	Finding more information about activation


	Security
	How do I set up security in RSNetWorx?
	What can I secure in RSNetWorx?

	Glossary
	Index
	A
	C
	D
	E
	F
	G
	H
	I
	L
	M
	N
	O
	P
	Q
	R
	S
	T
	U
	W
	Z


